2015年6月5日金曜日

[GL07S]GL07S_kitkat_150531.zip をインストールしてみた

659 名前:SIM無しさん[] 投稿日:2015/05/28(木) 22:33:55.98 ID:KyB7VRGZ
今4.4のテストしてますが需要があれば明日にでもうpします

http://imgur.com/xuFfvcc.jpg
http://imgur.com/uNk04Gi.jpg
http://imgur.com/YdoZZHt.jpg
http://imgur.com/l3jT1Pj.jpg
http://imgur.com/HCODN39.jpg

【ROM焼き】EMOBILE STREAM X GL07S root1


668 名前:659[] 投稿日:2015/05/31(日) 21:45:28.67 ID:jCUKAaHL
GL07S_kitkat_150531.zip
https://mega.co.nz/#!Xxdxjb7b!YiFC5mzN3dd1wPE7HPkAY1-4WS4S00A8cibSefoiouo

openrecovery-twrp-2.8.1.0.img
https://mega.co.nz/#!qw0S2IgI!8bcxzRmFZcVMkbKjFsuzjBumEDb6BhomMLa_gmeJbkI

インストール方法:
1 TWRP2.8.1.0をインストール
fastboot flash recovery openrecovery-twrp-2.8.1.0.img
2 zipファイルを内部ストレージにコピー
3 TWRPを起動
4 Install → (Up A Level) → emmc → GL07S_kk_150531.zip → Swipe to Confirm Flash → 勝手に再起動 →

→ Yes → reboot system now

【ROM焼き】EMOBILE STREAM X GL07S root1
ちょっと引用部分が長くなりましたが
私の使用環境でも再起動時に文鎮にならなくなったので、スクリーンショットなどを
*USBデバッグ有効の仕方がわからないので最低限の画像だけですが


2chに貼られていた画像を見る限りでは、P6ベースのカスタムROMの様です(EMUIを搭載していることからも明らか?)


EMUI

674 名前:SIM無しさん[sage] 投稿日:2015/06/02(火) 01:06:35.66 ID:fupDDYI7 [1/2]
動いてたけど文鎮になった(データ領域のwipeで復旧はできる)
何が原因かは特定できず

675 名前:SIM無しさん[sage] 投稿日:2015/06/02(火) 02:40:49.84 ID:fupDDYI7 [2/2]
なんかよくわからんがROM焼いた後にTWRP焼いてTWRPでdata領域ワイプすると再起動しても文鎮にならなくなった。
ROMに入ってるrecoveryじゃ駄目っぽい?

【ROM焼き】EMOBILE STREAM X GL07S root1
でまぁ、2chで報告されている様に、ROM焼き後TWRPからワイプしないと再起動しない状態に陥ります

ROM焼き後にインストールされるリカバリから
wipe data/factory reset せず再起動
で、fastbootに入ってまたTWRPを焼いてTWRPからワイプ(スライドだけ)でokでした

ROM自体はぬるぬるしていて快適です
権限管理機能などもあり、リアルタイムでアクセスを拒否したりできます

ただ、2chの報告にある様にカメラが残念な様ですが、これはカスタムROMの宿命なので仕方がないですね
あとはハードウェアキーが使えないのでナビゲーションバーで画面が小さくなってしまう事くらいでしょうか

私はGL07S二号機で実践したのでTWRPでのバックアップしか取りませんでしたが
(結局ワイプしたので消えた)
バックアップはきちんと取りましょう(笑)

関連エントリ:

F(uriouz)

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation.
comments powered by Disqus

12 コメント:

  1. はじめまして。
    コメント失礼します。

    こちらの記事を参考にkitkatを導入するに辺り確認したくてコメントしました。

    大前提として、現在の自分の所有しているGL07SのOSのビルド番号B207なのですが導入可能なのでしょうか?
    また、カスタムROM導入自体にROOT化は特にしなくても出来るって認識で良いのでしょうか?

    そして、導入手順としてはこちらで紹介されている下記の記事を順を追って行けば完了ですか?
    ・Android SDKのインストール
    ・[GL07S]ドライバのインストール
    ・[GL07S]ブートローダーアンロックからTWRP導入まで
    ・[GL07S]GL07S_kitkat_150531.zip をインストールしてみた


    加えて使用するROMファイル等は下記の物でOKですか?
    http://gl07s.nakayuki.net/public/gl07s-kk/

    質問ばかりで恐縮ですが、ご多忙かと思いますがご回答頂けたら幸いです。
    よろしくお願いいたします。

    返信削除
  2. はじめまして

    ブートローダーアンロックはビルド番号に関係なく行えるかと思います
    ROOT化は関係ありません

    手順は書かれている通りです
    Android SDKのインストールについては情報が古いこともありますので、うまくいかない場合は最新の情報もチェックしてみてください

    ROMファイル等は(有志の方がミラーしてくださっているものなので)それでOKです

    返信削除
    返信
    1. F(uriouz) 様

      その後の経過です。
      PCとADBデバック許可状態で接続してブートローダー状態で、コマンドプロンプトからアンロックコード入れましたがロック解除が出来ません。

      おまけにコマンドプロンプトで、ファイルのドラッグアンドドロップができない不具合も有って作業が進まないです。
      OSは10ですが、以前他のAndroid端末のROOT化した際は7で問題なかったので原因は10だからでしょうか?

      2chスレやネットの他サイト等で調べても原因が不明です。
      最悪7でないと無理なのでしょうか?

      何か情報をお持ちでしたらご提供下さい。

      削除
  3. F(uriouz) 様
    丁寧なご回答感謝します。

    Android SDKのインストールは別の端末のROOT化で利用するために、既にPCにインストールしているので、実際にはGL07Sのドライバインストール以降の作業になりそうです。

    ご多忙中のご回答ありがとうございました。

    返信削除
  4. まず、接続されたデバイスは認識されていますでしょうか
    fastboot devices とコマンドを打ってみてください

    通常であればこの様な結果になると思います
    GL07SのBootloader Unlockとカスタムリカバリー ~ ガジェットのある日常
    http://advancedbear.blogspot.jp/2014/04/gl07s-unlock-and-twrp.html

    ドライバがインストールされていて、認識できない場合は、OSによる環境依存の可能性が高いかもしれないです

    また、TWRPはブートローダーアンロック後でないと導入できません
    コマンドプロンプトで、ファイルのドラッグアンドドロップができない場合は
    直接ファイルのパスを入力して下さい

    返信削除
    返信
    1. 回答有り難うございます

      その後、原因は不明ですがTWRPの導入までは何故か出来ました。

      ですが、今度はrebootしてもノーマルのシステムが起動しない状態となりEMロゴでループ状態です。

      音量↑+電源で(PCにUSB接続したまま)でTWRPは起動します。
      仕方ないのでその状態で、コマンドプロンプトからadb pushでカスタムロムのzipファイルをコピーしようと試みますがコピー途中の79%でコピーが停止して進みません。

      ネットでコピーが止まる原因を調べても不明。
      行き詰まっているのが現状です。

      削除
  5. TWRPを起動した状態でPCに接続したら
    Internal Storage を直接開けませんかね?
    後は内部ストレージにROMファイルをコピーして、TWRPからインストールすればいけるかなと思うのですが

    返信削除
    返信
    1. Internal Storageは開けますが、コピー(転送)すると「転送しています」の状態で転送されずに最後は「デバイスが応答しなくなっているか、接続が解除されています。」が出てコピーが出来ないです。

      削除
    2. F(uriouz) 様

      あれから試行錯誤の末…kitkatの導入に成功しました。

      ネックだったzipファイルのコピーは…

      1.GL07S_kitkat_150531.zipを一旦PCで解凍

      2.解凍した中のrecovery.imgをfastboot flashで焼き直して一旦、ノーマルリカバリーに戻す。⇒ノーマルのAndroid4.1.2のシステムが起動できるようになる。

      3.PCとMTP接続でGL07S_kitkat_150531.zipをコピー(問題なく出来ました。)

      4.fastboot flashで改めてTWRPを導入。

      5.TWRPからGL07S_kitkat_150531.zipをインストール

      6.再起動後、wipe data/factory resetを実行

      7.reboot

      …これで成功しました。

      原因は正直良くわかりませんがようやくどうにかなりました。
      たくさんのご助言に感謝致します。
      とりあえずは不具合無く動作しております。
      ありがとうございました。

      削除
    3. F(uriouz) 様

      昨晩は安定動作していましたが、再起動したらEMロゴループになってしまってどうにもならず…
      標準リカバリーでwipe data/factory resetを実行してrebootすると立ち上がりますが当然全て初期状態。
      …再起動や電源OFFをしなければ何とか動作する状態です。
      どうにも不具合が多くて酷いのでB207ノーマルに戻して見ます。

      削除
  6. ですよねぇ
    リカバリ戻すしかないですよねぇ

    私の環境では再起動も問題なくできているのですが
    おそらく、ワイプの手順が間違っているのではないかなと
    一度でも起動させてしまうと駄目だった様な気が

    返信削除
    返信
    1. F(uriouz) 様

      その後、めげずに何度もトライしても変わりませんでした。(T_T)

      ですが…
      kitkat導入自体は成功するのに、1度でも「再起動」するとEMロゴループ…

      では「再起動」ではなく「シャットダウンして改めて電源ON」ならどうだ?
      と、半ばヤケクソの疑問に突き動かされやったら…

      その後はEMロゴループに入らず正常に起動!!

      都合10数回やり直して理由がそれかよって気がして、脱力感が半端ないです。

      ちなみにそのヒントは…
      http://qiita.com/matobaa/items/6b85d28e046bf4660fcd
      こちらの記事に記載の内容でピンときました^^;

      現在はあのEMロゴループ地獄がウソのように快適動作しています。

      ですが、EMロゴループが怖くて「再起動」は避けています。

      色々と教えて頂きありがとうございました。

      削除

注: コメントを投稿できるのは、このブログのメンバーだけです。

Recent Posts

 

Copyright @ 2013 - FPS(Furiouz Personal Side).

Designed by Templateism | MyBloggerLab | Modified by F(uriouz)

"The Android robot is reproduced or modified from work created and shared by Google and used according to terms described in the Creative Commons 3.0 Attribution License."